How to Configure AppArmor/SELinux Equivalents on FreeBSD Operating System
Categories:
3 minute read
Security is a primary concern in any operating system, and Linux users are accustomed to using Mandatory Access Control (MAC) frameworks like AppArmor and SELinux to enhance system security. However, FreeBSD, a Unix-like operating system, does not support these Linux-based tools directly. Instead, FreeBSD provides its own MAC framework, offering similar functionality to AppArmor and SELinux. This guide will explore how to configure FreeBSD’s native security frameworks as equivalents to AppArmor and SELinux.
Understanding FreeBSD’s MAC Framework
FreeBSD’s security architecture includes the Mandatory Access Control (MAC) framework, which provides fine-grained access control policies similar to SELinux and AppArmor. The MAC framework allows administrators to enforce restrictions beyond standard Unix discretionary access controls (DAC), enhancing security at the kernel level.
FreeBSD provides multiple MAC modules, such as:
- mac_bsdextended: Implements an access control policy similar to Linux’s capabilities.
- mac_mls: Implements Multi-Level Security (MLS), akin to SELinux.
- mac_lomac: A lower-overhead alternative to mac_mls, enforcing hierarchical security labels.
- mac_partition: Restricts inter-process communication between partitions.
- mac_none: A null policy that disables MAC controls.
Enabling the FreeBSD MAC Framework
To use FreeBSD’s MAC framework, ensure that your system has the required modules loaded. Most modern FreeBSD installations include the MAC framework by default, but it may need to be explicitly enabled.
1. Verify Kernel Support
Check whether the MAC framework is enabled on your system by running:
sysctl security.mac
If the output shows security.mac.*
parameters, the framework is available.
2. Load the MAC Modules
To load a specific MAC module, use the kldload
command. For example, to load the mac_bsdextended
module:
kldload mac_bsdextended
To make this change persistent across reboots, add the module to /boot/loader.conf
:
echo 'mac_bsdextended_load="YES"' >> /boot/loader.conf
Repeat the process for other modules you want to use.
3. Enable MAC Policies in rc.conf
After loading the modules, enable the MAC framework by adding the following line to /etc/rc.conf
:
sysrc security.bsdextended.enable=YES
Then restart your system for the changes to take effect:
reboot
Configuring MAC Policies
Once the MAC framework is enabled, you can configure policies similar to SELinux or AppArmor.
1. Using mac_bsdextended
The mac_bsdextended
module allows defining rules similar to Linux’s capabilities
module.
To list current policies:
ugidfw list
To add a rule that prevents user testuser
from executing binaries in /usr/local/bin/
:
ugidfw add subject uid testuser object type file mode deny:execute path /usr/local/bin
To make this persistent, add the rule to /etc/mac.conf
:
subject uid testuser object type file mode deny:execute path /usr/local/bin
2. Configuring mac_mls
for SELinux-like MLS Enforcement
SELinux provides Multi-Level Security (MLS), which can be replicated using FreeBSD’s mac_mls
module.
To enable MLS enforcement, add the following to /boot/loader.conf
:
mac_mls_load="YES"
Then, label files and processes:
setfmac mls/high /secure/data
To check MLS labels:
getfmac /secure/data
3. Implementing Application Sandboxing with mac_partition
For a more application-specific security model similar to AppArmor, use mac_partition
to sandbox processes.
To assign a process to a partition:
setpmac partition/1 /usr/local/bin/some_application
To check partition assignments:
ps -ax -o label,command
Testing and Troubleshooting
After configuring MAC policies, test them to ensure they behave as expected. For example, to verify that testuser
cannot execute files in /usr/local/bin/
:
su - testuser -c '/usr/local/bin/some_binary'
If access is denied, the policy is correctly enforced.
To troubleshoot:
Check system logs:
dmesg | grep mac
Use
sysctl security.mac
to verify loaded policies.Ensure the MAC modules are correctly loaded in
/boot/loader.conf
.
Conclusion
While FreeBSD does not natively support SELinux or AppArmor, its built-in MAC framework provides equivalent security controls. By enabling and configuring mac_bsdextended
, mac_mls
, and mac_partition
, administrators can implement fine-grained security policies similar to those available in Linux-based MAC frameworks. With proper configuration and testing, FreeBSD’s security model can achieve robust application containment, access control, and system hardening comparable to AppArmor and SELinux.
Feedback
Was this page helpful?
Glad to hear it! Please tell us how we can improve.
Sorry to hear that. Please tell us how we can improve.