How to Enable Linux Binary Compatibility (Linuxulator) on FreeBSD Operating System
Categories:
4 minute read
FreeBSD is a powerful and flexible operating system that supports running native FreeBSD applications as well as software designed for other UNIX-like systems. One of its most useful features is Linux binary compatibility, often referred to as “Linuxulator.” This feature allows FreeBSD to run Linux programs, including proprietary applications that may not be natively available for FreeBSD.
Enabling Linuxulator on FreeBSD requires configuring the kernel, setting up the necessary libraries, and installing a compatible Linux userland. This guide will walk you through the steps needed to enable and configure Linux binary compatibility on FreeBSD.
1. Understanding Linux Binary Compatibility in FreeBSD
The Linux binary compatibility layer in FreeBSD works by intercepting system calls made by Linux applications and translating them into FreeBSD equivalents. This enables Linux applications to run without modification. However, the compatibility layer does not emulate the Linux kernel but instead provides an environment that mimics Linux system calls, libraries, and files.
FreeBSD includes support for running Linux binaries as a kernel module, which can be loaded dynamically when needed. Additionally, FreeBSD provides Linux distributions like CentOS and Debian as userland environments that complement this compatibility layer.
2. Checking FreeBSD Version and Kernel Compatibility
Before enabling Linuxulator, ensure that your FreeBSD system is compatible:
freebsd-version
uname -r
Ensure you are running FreeBSD 12.x, 13.x, or a later version, as they provide better support for Linux binary compatibility.
3. Enabling the Linux Kernel Module
To enable Linux binary compatibility, load the required kernel module:
sudo kldload linux
sudo kldload linux64
To make these changes persistent across reboots, add the following lines to /etc/rc.conf
:
linux_enable="YES"
And to /boot/loader.conf
:
linux_load="YES"
linux64_load="YES"
Verify that the modules are loaded:
kldstat | grep linux
If both linux.ko
and linux64.ko
appear in the output, the modules are successfully loaded.
4. Installing the Linux Base System
FreeBSD provides a Linux userland environment that allows Linux applications to function correctly. The linux_base
package contains essential Linux libraries and binaries.
To install a Linux base system (CentOS 7 is commonly used):
sudo pkg install linux_base-c7
Once installed, enable the Linux environment:
sudo sysrc linux_enable="YES"
sudo service linux start
To check if Linux compatibility is enabled:
sysctl compat.linux.osrelease
This should return a Linux kernel version, such as 3.10.0
(CentOS 7). If not, set it manually:
sudo sysctl compat.linux.osrelease=3.10.0
To make this persistent across reboots, add the following to /etc/sysctl.conf
:
compat.linux.osrelease=3.10.0
5. Configuring Linux File System Support
Some Linux applications require specific file system structures to function properly. FreeBSD provides /compat/linux/
as the root directory for the Linux userland.
Ensure that necessary directories exist:
sudo mkdir -p /compat/linux/proc
sudo mkdir -p /compat/linux/sys
sudo mkdir -p /compat/linux/dev
Mount the required file systems:
sudo mount -t linprocfs linproc /compat/linux/proc
sudo mount -t linsysfs linsys /compat/linux/sys
sudo mount -t devfs devfs /compat/linux/dev
To make these mounts persistent, add the following lines to /etc/fstab
:
linproc /compat/linux/proc linprocfs rw 0 0
linsys /compat/linux/sys linsysfs rw 0 0
devfs /compat/linux/dev devfs rw 0 0
6. Running Linux Applications on FreeBSD
Once Linux binary compatibility is set up, you can run Linux applications. Test by running a basic Linux binary, such as the ls
command from the Linux base package:
/compat/linux/bin/ls -l /
If you need to install additional Linux applications, use the FreeBSD package manager or manually install RPM-based software using tools like dnf
(for CentOS-based environments).
For example, to install bash
in the Linux environment:
sudo pkg install linux-c7-bash
Launch the Linux version of Bash:
/compat/linux/bin/bash
7. Installing and Running Steam or Proprietary Linux Software
If you want to run Linux-based proprietary software like Steam, you may need additional libraries and 32-bit compatibility:
sudo pkg install linux-steam-utils
For NVIDIA users, install the Linux graphics drivers:
sudo pkg install linux-nvidia-libs
Some applications might require pulseaudio
for sound:
sudo pkg install linux-c7-pulseaudio
Run Steam using:
linux-steam
8. Troubleshooting Linux Binary Compatibility
If a Linux application fails to run, check for missing libraries:
ldd /compat/linux/bin/bash
If missing dependencies appear, install the required packages.
Check kernel logs for errors:
dmesg | grep linux
If an application does not work, try using an alternative Linux base system like linux_base-debian
:
sudo pkg install linux_base-debian
To remove Linux compatibility, disable it and remove the installed components:
sudo sysrc linux_enable="NO"
sudo service linux stop
sudo pkg delete linux_base-c7
Conclusion
Enabling Linux binary compatibility (Linuxulator) on FreeBSD allows users to run Linux applications seamlessly. By loading the necessary kernel modules, installing a Linux base system, and configuring the environment, FreeBSD users can expand their software options significantly. Whether running simple command-line utilities or complex GUI applications like Steam, Linuxulator makes FreeBSD a versatile and powerful operating system for diverse use cases.
Feedback
Was this page helpful?
Glad to hear it! Please tell us how we can improve.
Sorry to hear that. Please tell us how we can improve.