How to Reset Kernel Settings to Defaults on FreeBSD
Categories:
6 minute read
FreeBSD, one of the most stable and high-performance Unix-like operating systems, provides administrators with extensive control over kernel behavior through various tunable parameters. While this flexibility is powerful, it can sometimes lead to problematic configurations or performance issues that require restoring kernel settings to their default values. This comprehensive guide explores the process of resetting kernel parameters to their defaults on FreeBSD systems.
Understanding FreeBSD Kernel Configuration
Before diving into reset procedures, it’s important to understand how FreeBSD manages kernel configurations and which files control these settings.
Key Configuration Files
FreeBSD’s kernel behavior is controlled through several configuration mechanisms:
- /boot/loader.conf - Contains boot-time kernel tunable parameters
- /etc/sysctl.conf - Contains runtime kernel parameters
- /etc/rc.conf - Contains system configuration settings that may affect kernel behavior
- Custom kernel configuration - If you’ve built a custom kernel
These files allow administrators to modify various aspects of kernel behavior, from memory management to network stack settings.
Identifying Current Kernel Settings
Before resetting, it’s useful to understand your current configuration to determine what needs to be restored to defaults.
Checking Loader Settings
To view the current loader settings:
# Display all loader settings
sysctl -a | grep "loader"
# Alternative: view boot-time loader tunables
grep -v "^#" /boot/loader.conf
Checking Sysctl Parameters
To view current kernel parameters:
# View all kernel settings
sysctl -a
# Filter for specific subsystems, e.g., network settings
sysctl -a | grep net
Resetting Loader Configuration
The /boot/loader.conf
file and its associated /boot/loader.conf.local
contain boot-time kernel tunables that are applied during system initialization.
Creating Backup Copies
Always create backups before making changes:
cp /boot/loader.conf /boot/loader.conf.bak
cp /boot/loader.conf.local /boot/loader.conf.local.bak 2>/dev/null
Removing Custom Settings
To reset to defaults, you can either:
- Comment out all custom settings by prefixing lines with
#
- Remove the file contents entirely
# Option 1: Comment out all non-comment lines
sed -i '' 's/^[^#]/#&/' /boot/loader.conf
# Option 2: Clear the file (preserving defaults)
echo "# Restored to defaults on $(date)" > /boot/loader.conf
For /boot/loader.conf.local
, if it exists:
rm /boot/loader.conf.local
Resetting Sysctl Parameters
The sysctl utility allows viewing and modifying kernel parameters on a running system. Settings in /etc/sysctl.conf
persist across boots.
Backing Up Current Settings
cp /etc/sysctl.conf /etc/sysctl.conf.bak
Removing Custom Settings
To reset to defaults:
# Comment out all non-comment lines
sed -i '' 's/^[^#]/#&/' /etc/sysctl.conf
# Alternatively, clear the file
echo "# Restored to defaults on $(date)" > /etc/sysctl.conf
Applying Default Values to Running System
For some parameters, you may need to explicitly reset them on the running system:
# Example: Reset specific parameter to default
sysctl kern.ipc.somaxconn=128 # Replace with actual default
# For network settings
sysctl net.inet.tcp.delayed_ack=1 # Example default
Finding the default values can be challenging. You can:
- Consult FreeBSD documentation
- Boot from installation media and check values
- Consult
/usr/src/sys/*/NOTES
files for documented defaults
Resetting System RC Configuration
Some kernel-related settings are controlled through /etc/rc.conf
:
Backing Up RC Configuration
cp /etc/rc.conf /etc/rc.conf.bak
Removing Kernel-Related Settings
Edit /etc/rc.conf
and remove or comment out lines that affect kernel behavior:
# Common kernel-related settings to check
# firewall_enable="YES"
# gateway_enable="YES"
# ipfw_load="YES"
# pf_enable="YES"
# kern_securelevel_enable="YES"
Handling Custom Kernels
If you’ve built and installed a custom kernel, resetting to defaults means reverting to the GENERIC kernel:
Identifying Current Kernel
uname -i # Shows kernel identifier
Restoring GENERIC Kernel
If your system boots from the GENERIC kernel but uses a custom one:
Edit
/boot/loader.conf
and remove or comment out any lines settingkernel=
to a custom valueAlternatively, add or modify:
kernel="GENERIC"
Rebuilding and Installing GENERIC Kernel
If you don’t have the GENERIC kernel available:
# Navigate to source directory (if installed)
cd /usr/src
# Configure and build GENERIC kernel
make buildkernel KERNCONF=GENERIC
make installkernel KERNCONF=GENERIC
If source is not installed:
# Install source first
pkg install git
git clone https://git.FreeBSD.org/src.git /usr/src
cd /usr/src
git checkout releng/$(uname -r | cut -f1,2 -d'.')
# Then build and install GENERIC kernel
make buildkernel KERNCONF=GENERIC
make installkernel KERNCONF=GENERIC
Handling Kernel Modules
Kernel modules can also modify system behavior:
Listing Loaded Modules
kldstat
Unloading Non-Default Modules
kldunload module_name
Preventing Modules from Loading at Boot
Edit /boot/loader.conf
and comment out or remove lines that load custom modules.
Special Consideration: ZFS Settings
If you’re using ZFS, there are specific kernel parameters that might need attention:
Viewing ZFS Parameters
sysctl -a | grep vfs.zfs
Resetting ZFS Parameters
ZFS parameters often have their defaults listed in the output of:
sysctl -d vfs.zfs.some.parameter
To reset:
# Example
sysctl vfs.zfs.prefetch_disable=0 # Default is usually 0
Testing Your Changes
After making changes, testing is crucial:
Immediate Testing
For sysctl changes that don’t require a reboot:
# Example: Test network stack
ping -c 3 localhost
ping -c 3 1.1.1.1
Reboot Testing
For loader.conf and other boot-time changes:
# Reboot the system
shutdown -r now
After rebooting, verify settings:
sysctl -a > after_reset.txt
Troubleshooting After Reset
Common Issues
Boot Failures: If you encounter boot failures:
- Boot into single-user mode by selecting this option at the boot menu
- Mount the root filesystem:
mount -u /; mount -a -t ufs
- Restore your backup:
cp /boot/loader.conf.bak /boot/loader.conf
Performance Issues: If you experience performance degradation:
- Some defaults may not be optimal for your hardware
- Consider tuning specific parameters based on documented best practices
Network Connectivity Problems:
- Check network interface configuration:
ifconfig
- Restore specific network parameters if needed
- Check network interface configuration:
Verifying Reset Success
To confirm your reset was successful:
# Compare current settings with defaults
# If you have access to another default FreeBSD installation:
diff -y current_settings.txt default_settings.txt
Best Practices for Kernel Configuration Management
Documentation
Always document your changes:
# Add comments in configuration files
# Example:
# Modified on 2025-03-20 by admin for high-traffic web server
Configuration Tracking
Consider using version control for configuration files:
# Initialize a Git repository for tracking
cd /etc
git init
git add rc.conf sysctl.conf
git commit -m "Initial configuration state"
Incremental Changes
Rather than making multiple changes at once:
- Make one change at a time
- Test thoroughly
- Document the effect
- Move to the next parameter
This methodology makes troubleshooting much easier.
Conclusion
Resetting FreeBSD kernel settings to their defaults can resolve various system issues and provide a clean slate for optimization. The process involves understanding the configuration files, creating proper backups, carefully removing custom settings, and methodically testing the system after changes.
While default settings are designed to work well for general-purpose use, remember that production systems often benefit from tuning specific parameters based on their workload. After resetting to defaults, consider employing a structured approach to performance tuning by making documented, incremental changes guided by system monitoring and FreeBSD best practices.
By following this guide, system administrators can confidently restore FreeBSD systems to their default kernel configurations, resolving issues and creating a solid foundation for future optimization.
Feedback
Was this page helpful?
Glad to hear it! Please tell us how we can improve.
Sorry to hear that. Please tell us how we can improve.