Power Management Configuration for Laptops on FreeBSD

Learn how to configure power management for laptops running FreeBSD.

Power management is a critical aspect of laptop computing, directly affecting battery life, system performance, and overall user experience. FreeBSD, a robust and efficient Unix-like operating system, offers comprehensive power management capabilities that can be configured to optimize laptop battery usage while maintaining system functionality. This article provides a detailed guide on configuring power management for laptops running FreeBSD.

Understanding FreeBSD Power Management Components

FreeBSD implements power management through several interconnected components:

  1. ACPI (Advanced Configuration and Power Interface) - The primary framework for power management that interfaces between hardware, firmware, and the operating system.
  2. APM (Advanced Power Management) - An older power management standard, typically used when ACPI is unavailable or problematic.
  3. CPU Frequency Scaling - Adjusts processor speed based on system load to conserve power.
  4. Device Power States - Controls power consumption of individual devices.
  5. System Sleep States - Manages system-wide power modes (S1-S5).

Understanding these components is essential for effective power management configuration on FreeBSD.

Prerequisites

Before beginning power management configuration, ensure:

  • FreeBSD 13.0 or later is installed (though most instructions apply to earlier versions as well)
  • You have root or sudo access
  • Your laptop hardware supports ACPI (most modern laptops do)
  • The system is up-to-date with the latest patches

Basic ACPI Configuration

ACPI is the cornerstone of modern power management. To ensure ACPI is properly enabled:

  1. Check if ACPI is loaded by running:

    # kldstat | grep acpi
    
  2. If not loaded, add the following to /boot/loader.conf:

    acpi_load="YES"
    
  3. For comprehensive ACPI support, include these additional modules:

    acpi_video_load="YES"
    acpi_ibm_load="YES"    # For ThinkPads
    acpi_asus_load="YES"   # For ASUS laptops
    acpi_toshiba_load="YES" # For Toshiba laptops
    
  4. Ensure the following line exists in /etc/rc.conf:

    acpi_enable="YES"
    
  5. Restart the system or load the modules manually:

    # kldload acpi
    

Power State Control

FreeBSD supports various power states that can be managed to conserve battery:

Sleep and Suspend States

To enable suspend-to-RAM (S3 state):

  1. Add to /etc/rc.conf:

    hw.acpi.suspend_state="S3"
    
  2. To trigger sleep mode manually:

    # acpiconf -s 3
    
  3. Configure suspend on lid close by adding to /etc/sysctl.conf:

    hw.acpi.lid_switch_state=S3
    

Hibernation (Suspend-to-Disk)

FreeBSD’s hibernation support is less mature than some other operating systems but can be configured:

  1. Create a swap partition at least as large as your RAM

  2. Add to /boot/loader.conf:

    hw.acpi.s4bios="1"
    
  3. To hibernate manually:

    # acpiconf -s 4
    

CPU Frequency Scaling

Dynamic CPU frequency scaling (also known as CPU throttling) can significantly reduce power consumption:

  1. Load the necessary kernel module by adding to /boot/loader.conf:

    coretemp_load="YES"
    
  2. Enable PowerNow or SpeedStep (depending on your CPU):

    # sysctl dev.cpu.0.freq_levels
    

    This displays available frequency levels.

  3. Add to /etc/rc.conf:

    powerd_enable="YES"
    powerd_flags="-a adaptive -b adaptive"
    
  4. Start the powerd daemon:

    # service powerd start
    
  5. To verify it’s working:

    # sysctl dev.cpu.0.freq
    

The powerd daemon automatically adjusts CPU frequency based on system load. The -a adaptive flag sets adaptive mode when on AC power, while -b adaptive sets adaptive mode on battery.

Advanced powerd Configuration

For more precise control over powerd behavior:

  1. Customize performance profiles in /etc/rc.conf:

    powerd_flags="-a hiadaptive -b adaptive -n adaptive -i 85 -r 60 -p 100"
    

    Where:

    • -a hiadaptive: High-performance adaptive mode on AC
    • -b adaptive: Standard adaptive mode on battery
    • -n adaptive: Standard adaptive mode when “normal”
    • -i 85: CPU usage percentage to trigger upscaling
    • -r 60: Poll rate in milliseconds
    • -p 100: Maximum performance percentage
  2. For extreme battery conservation:

    powerd_flags="-a adaptive -b minimum -i 95 -r 100"
    

    This sets the CPU to minimum frequency when on battery.

Graphics Power Management

Graphics processors can be significant power consumers. Configure them properly:

Intel Graphics

  1. Add to /boot/loader.conf:

    drm.i915.enable_rc6="7"
    drm.i915.semaphores="1"
    drm.i915.enable_fbc="1"
    
  2. For Intel HD 4000 or newer, add:

    drm.i915.enable_psr="1"
    

NVIDIA Graphics with Optimus Technology

For laptops with dual graphics (Intel + NVIDIA):

  1. Install the necessary packages:

    # pkg install nvidia-driver bumblebee
    
  2. Add to /etc/rc.conf:

    bumblebeed_enable="YES"
    
  3. Add your user to the bumblebee group:

    # pw groupmod bumblebee -m yourusername
    
  4. Start the service:

    # service bumblebeed start
    

Device-Specific Power Management

Individual devices can be managed for optimal power usage:

USB Power Management

  1. Add to /boot/loader.conf:

    hw.usb.no_suspend_wait="1"
    hw.usb.power_timeout="30000"
    
  2. To disable specific USB devices when on battery, create custom devd scripts.

Disk Power Management

  1. For SSD/HDD power saving, add to /etc/sysctl.conf:

    hw.ata.standby_timeout="900"  # 15 minutes timeout
    
  2. For additional power savings with hdparm:

    # pkg install hdparm
    # hdparm -B 127 /dev/ada0  # Medium power saving
    

Network Interfaces

  1. Disable Wi-Fi when not in use:

    # ifconfig wlan0 down
    
  2. Add to /etc/rc.conf for Wake-on-LAN control:

    ifconfig_em0="WOL"  # Enable Wake-on-LAN
    

Battery Monitoring and Management

Keeping track of battery status is important for power management:

  1. Install battery monitoring tools:

    # pkg install acpi_call
    # pkg install battray  # GUI battery monitor
    
  2. View battery statistics:

    # acpiconf -i 0
    
  3. For detailed battery information:

    # sysctl hw.acpi.battery
    

Power Management Scripts and Automation

Creating scripts for different power scenarios can enhance battery life:

Power Profile Scripts

Create /usr/local/bin/powersave.sh:

#!/bin/sh
# Power saving mode
sysctl hw.snd.latency=7
sysctl hw.pci.do_power_nodriver=3
sysctl dev.cpu.0.freq=800  # Set to your CPU's lowest frequency
ifconfig wlan0 powersave on

Create /usr/local/bin/performance.sh:

#!/bin/sh
# Performance mode
sysctl hw.snd.latency=2
sysctl hw.pci.do_power_nodriver=0
sysctl dev.cpu.0.freq=`sysctl -n dev.cpu.0.freq_levels | cut -d '/' -f1`
ifconfig wlan0 powersave off

Make them executable:

# chmod +x /usr/local/bin/powersave.sh /usr/local/bin/performance.sh

Automatic Profile Switching

Configure automatic switching based on power source:

  1. Install the devd event handling system if not already present.

  2. Create /usr/local/etc/devd/power.conf:

notify 10 {
    match "system"          "ACPI";
    match "subsystem"       "ACAD";
    match "notify"          "0x00";
    action "/usr/local/bin/powersave.sh";
};

notify 20 {
    match "system"          "ACPI";
    match "subsystem"       "ACAD";
    match "notify"          "0x01";
    action "/usr/local/bin/performance.sh";
};
  1. Restart the devd service:
# service devd restart

Desktop Environment Integration

If using a desktop environment, configure its power management settings:

XFCE Power Manager

  1. Install XFCE power manager:
# pkg install xfce4-power-manager
  1. Configure through the GUI or via XML configuration files in ~/.config/xfce4/xfconf/xfce-perchannel-xml/.

KDE Power Management

  1. Use KDE’s built-in Power Management System Settings.

  2. Ensure it doesn’t conflict with system-level settings.

Troubleshooting Common Issues

Power Management Not Working

  1. Check if ACPI is properly loaded:
# dmesg | grep -i acpi
  1. Verify if your hardware is fully supported:
# acpidump -dt
  1. Try loading APM instead of ACPI if hardware support is problematic:
# echo 'apm_load="YES"' >> /boot/loader.conf
# echo 'acpi_load="NO"' >> /boot/loader.conf

System Hangs on Resume

  1. Add to /boot/loader.conf:
hw.acpi.reset_video="1"
  1. If issues persist, try disabling some devices before suspend:
# echo 'beforeresume_devices="drm"' >> /etc/rc.suspend
# echo 'afterresume_devices="drm"' >> /etc/rc.resume

Battery Life Still Poor

  1. Install and run powertop to identify power-hungry processes:
# pkg install powertop
# powertop --auto-tune
  1. Check for background processes consuming power:
# top -a

Conclusion

Effective power management is essential for maximizing battery life and performance on FreeBSD laptops. By understanding and configuring ACPI, CPU frequency scaling, device power states, and implementing automated power profiles, users can significantly extend their laptop’s battery runtime while maintaining optimal system performance.

FreeBSD’s power management capabilities continue to evolve with each release, offering increasingly sophisticated control over system power consumption. Regular updates to the operating system and careful monitoring of power usage patterns will ensure your laptop runs efficiently under FreeBSD.

Remember that power management is often a balance between performance and battery life. The configurations suggested in this article provide a starting point, but optimal settings will vary based on specific hardware, usage patterns, and personal preferences. Experiment with different configurations to find the right balance for your needs.